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REMINDER: it is recommended to
create a folder for the workspace, for
instance inside the root folder
created for the software installation
(Development)

We open Eclipse and select the
workspace where we will store the
created projects.

We create a Tomcat server instance:

File=> New—=> Other=> Server—> Server

< Back MNext » Finish Cancel




1. Creation of a Tomecat Server 1n Eclipse (11)

* Select Tomcat 9 and click Next

* We select the folder where we
have installed the Tomcat and the
JRE we desire to use.

Define a New Server I
|| Choose the type of server to create
|

Select the server type:
type filter text

& Tomcat v5.0 Server
B Tomcatv5.5 Server
 Tomcat v6.0 Server
& Tomcat v7.0 Server

Tomcat Server

Specify the installation directory

Name:

Apache Tomcat v9.0

Tomcat installation directory:
C:\Development\apache-tomcat-9.0.0.M10

JRE:

* For the JRE we have to select the | Ew L
installed JDK. Usually, by default, e
it 1s JRE selected. If so, follow o
the steps in the following slide.
@ <bock [ Not> ][ fnsh ][ Conce Q) e e e
TR : IR RN




1. Creation of 4 lTemecat Seryet 1n Belipse (11

) Add RE i

=

How to select the JDK: Click on Installed [RE

|| JRE Definition

‘— i
e TR =
Specify attributes for a JRE by
Select the type of JRE to add to the workspace. ) "
Directory...

JRE home: C:\Program Files\Java\jdk1.8.0_101
Installed JRE Types:

* OPTION 1. If the JDK is not in the list, follow the

JRE 3 jdk1.8.0_101
S tep S b elOW: Execution Environment Description neme ! =
Standard 1.1x VM Default VM arguments:
Standard VM

JRE system libraries:

P C]jck On the Instaﬂed JRE% Add 9 Standard b (i C:\Program Files\Java\jdk1.8.0_101\jre\lib\resources.jar 4 || Add External JARs...

> (4 C:\Program Files\Java\jdk1.8.0_101\jre\lib\rt jar

b (i C:\Program Files\Java\jdk1.8.0_101\jre\lib\jsse jar Javadoc Location...

;/ M 9 N eXt b C:\Program Files\Java\jdk1.8.0_101\jre\lib\jce.jar A (Source Atachment..
b [ C:\Program Files\Java\jdk1.8.0_101\jre\lib\charsets.jar

>y C:\Program Files\Java\jdk1.8.0_101\jre\lib\jfr.jar External annotations...

b s C:\Program Files\Java\jdk1.8.0_101\jre\lib\ext\access-bi_|

C:\Program Files\Java\jdk1.8.0_101\jre\lib\ext\cldrdata. Remove

% In the pop_up Screen) SeleCt the fOlder Where the » fa C\Program Files\Java\jdk1.8.0_101\jre\lib\ext\dnsns.jar
\Program Files\Java\jdk1 8. : jrenlil jaccessja Up
JDI< is ins talled. Then C]ick On Finish ;a E;tzrogram il:es:JJava:j:E:gjgitjre::lztztjfxmarj Down

» fos C:\Program Files\Java\jdkl.8.0_101\jre\lib\ext\localedat ~

< 1] | » [W]
* Now follow OPTION 2 Steps ® T e ®

Next > [ Finish ] [ Cancel ]




1. Creation of a Tomcat Server in Eclipse (iv)

* OPTION 2. If the JDK is in the list:

Click on Installed JRE=> Select the
JDK and click OK.

It may happen that after clicking OK in
the following Windows the JRE i1s yet
selected. You have to open the
deployable list, select the JDK and
Finish.

Add, remove

Installed JREs

Installed JREs:

or edit JRE definitions, By default, the checked JRE is added to the build path of || |
newly created Java projects. ‘

= =
¥ :‘_O} New Server = -

.
i)l |
‘

Tomcat Server
Specify the installation directory

Name:

Apache Tomcat 3.0

Name

B\ jdk1.8.0_101 (default)
[T =i jdk1.8.0_25
[] =i jre1.8.0_45

Location

C:\Program Files\Java\jdk1.8....
C:\Program Files\Java\jdk1.8.0_...
C:\Program Files\Java\jrel.8.0_45

fdddes Tomcat installation directory:

m C:\Development\apache-tomcat-9.0.0.M10

Browse...
Downl

nload and Install...

JRE:
[ja.8.0201 ][ installed REs.. |
@ <Back || Net> [ Finish ][ cConcel




1. Creation of a Tomcat Server in Eclipse (v)

Start the Apache Tomcat server:

* In the down part of Eclipse, we have to click on the Server tab and there the Tomcat should be (Stopped):

Ul I B »

(2] Markers (] Properties &b Servers £2 & Data Source Explorer [ Snippets ) Console F3s Q8 e vy= 0
F_g@ Tomcat v8.0 Server at localhost [Stopped, Synchronized]

* In order to launch the server we right-click on it and select Start. We wait until the start is finished, once finished we
will see that the server status 1s Started, Synchronized:

< | 1 | }

{2 Markers [T Properties ' &b Servers 52 | Data Source Explorer 23 Snippets [E) Console Q& mE v= 0
% Tomcat v8.0 Server at localhost [Started, Syn;:hronized_]]

* NOTE: To see the servers view in Eclipse, Window=> Show View—=> Server = Servers.
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2. Dynamic Web Project Creation

* We create a Dynamic Web Project
named HelloWorld:

* New 2Dynamic Web Project

* Fill in Project name and select
the Tomcat recently created as
the Target runtime and =
Finish

°* VERY IMPORTANT: Respect
upper-case and lower-case

conventions for Java, specially for
the first letter

File | Edit Mavigate Search Project Run  Window Help
New Alt+Shift+N ¥ | 4" JPA Project
Open File... |'_=§ Enterprise Application Project
= - -
Close ChrleW |._3 Dynaric Web Project
Close All Ctreshift-w | 89 | EJB Project
ﬁ Connector Project
S Eis [ Application Client Project
Savehis.. G Static Web Project
Save All Ctrl+Shift+5 Mi  Maven Project
= ™ Project...
Rhoves & Serviet
Mz = [@ Session Bean (EJB 3.)
e % E§  Message-Driven Bean (EJB 3.x)
i irmni 2
Convert Line Delimiters To A | WebSenvice
Print... Ctrl+P | Folder
&
Switch Workspace »| LI | File
Restart ™ Example...
fug  Import.. 9  Other... Ctrl+M
by  Export...
Properties Alt+Enter
Exit
—

Dynamic Web Project 7
Create a standalone Dynamic Web project or add it te @ new o existing Enterprise Application. Le

Praject name: | HelloWorld
Project location
Use default location

Location: | C\Development\workspace\HelloWorld Browse...

Target runtime

Apache Tomcat v8.0 ~ | | New Runtime...

Dynamic web module version

3.1 v

Configuration
Default Configuration for Apache Tomcat v8.0 v | Modify..

A good starting point for working with Apache Tomcat v8.0 runtime. Additional facets can later be
installed to add new functienality to the project.

EAR membership
Add project to an EAR

EAF project name: | EAR New Project...

Waorking sets
[] Add project to working sets

Warking sets: Select..

@ < Back Next > Cancel
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3. Jersey Library Inclusion

* We copy Jersey libraries in WebContent/ WEB- _
INF/lib (we should have unzipped them previously) e

- 28 Java Resources

» mHi JavaScript Resources

* If they are not shown 1nside the folder after pasting
them, you should refresh the project (Right click on .

the project = Refresh) g

ackson-annotations-2.2.3.jar

ackson-core-2.2.3 jar

J
J
jackson-jaxrs-base-2.2.3 jar
jackson-jaxrs-json-provider-2.2.3.jar
jackson-module-jaxb-annetations-2.2
javax.annotation-api-1.2.jar
javax.inject-2.2.0-b14 jar [ Markers &2 | [ Properties| 4 Servers o
javax.servlet-api-3.0.1.jar 0

items
J
J
J
J
J
J
J

Description

(== lib - HelloWorld/WebContent/WEB-INF

2



Contents

Creation of a Tomcat Server in Eclipse
Dynamic Web project creation

Jersey library inclusion

Package and class creation

web.xml file creation

Service deployment in the service

ATl e i

Testing it from Postman

13




4. Package and Class Creation (1)

* We create a package

L] °
lnSIde the File Edit Mavigate S5earch Project Run Window Help Java Package i
Create a new Java package. g

C-EES \|I/‘ [T e T4

JavaResources/stc TR e e A o=k (

o -

. name p ackageN ame 2 5 project E;;: |l% Creates folders corresponding to packages.
+ 23 HelloWorld Source folder: | HelloWorld/src Browse...
> G Deployment Descr ame: nembrePagu
e VERY i Emil |N:| Create package-inbfo.J:v: EtEI
b oE Ja New b | Project...
IMPORTANT: e
[ é Servers & Interface
Respect upper-case & e
&% Source Folder
and lower-case 20 [rae
° “&  Listener
conventions for Java, & o
° =% ample..
specially for the first B
letter
T e ey e B i

14



4. Package and Class Creation (1t

* We create the class Hello and we o

Java Class

Create a new Java class.

@ ll

File Edit MNavigate Search Project Run Window Help
=~ = D ESES R ERE-O-R-B-E
. . .
introd th de in the followin e e |o
oduce the code e following P2t o | o |G
ER-S 5
> 4 2% HelloWorld An outline is not availa
|] j o
1 g Deplaym
N v Project...
S eo b AR AW = w G
4 23 Java Reso Go Into @  Annotation
- @§; Open Type Hierarchy f @ Cas
na
» m oy Showin Alt+Shift+ W » | @ Enum
°* VERY IMPORTANT' Respect e -dhad s
° b build e copy Qualified Name 8 Package
I & WebCont| - N
b B o [& Paste CuleV | BF HTMLFile
% Delete Delete | [& ISP File
upper-case and lower-case i conte [y
Build Path | 48 | itener
Source BltsSHS ¥ | o o
9 S Refactor Alt+Shift+T »
conventions 10r java SpeCIa y o
iy Import..
, A | Brsie % Other.. Ctrl+N
| |
>
&) Refresh ® | =
or € 11rst 1etter — . -
Debug As s
Run As » | Resource Path
Validate
Team 3
Compare With »
< Restore from Local History...
(88 o e Properties Alt+Enter

Source folder: HelleWorld/src Browse... i
Package: nombrePaquete Browse... |
["JEnclosing type: Browse...
Name: | Hellg|
Modifiers: (®) public () package private protected
[ abstract [final static
Superclass: Jjavalang.Object Browse...
Interfaces: Add...
Remowve
‘Which method stubs would you like to create?
O public static void main(String[] args)
[] Constructors from superclass
Inherited abstract methods
Do you want to add comments? (Configure templates and default value here
D Generate comments
®

15



4. Package and Class Creation (111

ackage packageName; W
P ge P g Use the package
nmneyouchgg;,

.GET;

import
import
import

import

Jjavax
javax
javax

javax

WS

.WS.

.WS.

.WS.

B g

S

rs

Xa

.Path;
.Produces;

.core.MediaType;

D

@Path ("/hello")
public class Hello {

@GET
@Produces (MediaType.TEXT PLAIN)

el si et ShisaayNieNs
sayPlainTextHello () {return "Hello
Plain";}

}

NOTE: Do not forget to save the file after pasting or
modifying the code

Use the class
name you chose
P

16
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5. web.xml File Creation (1)

* We create web.xml file
in WebContent/ WEB-
INF

* The XML editor opens
automatically. Click on
“Source” in the tab
below to see it in text

S;

File Edit Source Refactor Mavigate Search Project Run Window Help

O-E PS4 EMD

| 0 B R|FR

0 QU GG @B A DR D

Quick Access

25 | ¢ Java EE

mode.

* We copy the code in
the following slide and

we save it.

[ Project B 33| = T || ] Helllojave 1 |

I EREICE S

B 5| New

4 2 Helloworld
2

& G Deploy:

b 2@ JAX-WS Show In

4 2% Java Re:

Go Into

Ce
4 (3 src il
4 B {5 Copy Qualified Name
b [ [ Paste
& =i Libr{ 3¢ Delete
b g f‘fi’jm Remove from Context
3 ui
4 (= WebCo Build Path

L mE Mo
(= WEE Rename...
=4

b Servers I

Export...

EE

Refresh

Esi

Validate

Show in Remote Systems view
Profile As

Debug As

Run As

Team

Compare With

Restore from Local History...

< Source

(= WEB-INF - Hell P

» |4 Project...
(15 Fie |
Alt+Shift=W » | £ Folder
Citec | [ SQLFile
&7 HTMLFile
Cti+V | [&] ISP File
Dels % Example...
Ctrl+Alt+ Shift+Down
,|C% Other.. Curl+N
F2
F5

urce Explo... -u'\j Snippets. =

Resource Path

Alt+Enter

=S

LA

File

Create a new file resource,

Enter or select the parent folder:

HelloWorld/WebContent/ WEB-INF
B e o

4 2 HelloWorld
(= .settings
I+ = build
[+ = src
a (= WebContent
(= META-INF
[» = WEB-INF
L= RemoteSystemsTempFiles
b = Servers

File name: | webxml

@ Finish

Cancel

[€] webxml 22 | [J
1 <?xml wvers

22 <web-gpp »
3
4= gservlets
5 £zervlet
@ <zervlet
I <3
8
9_
16
11 <)
12 {zem i

13= ¢servlet-n
14 <zervle
15 <url-p:
16 </servlet-
17 </web-gpp:

18




5. web xml File Creation (1)

<xmliswwversion="l 0% encoding="ULk=g">>

<web-app xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-
. instance"”" xmlns="http://java.sun.com/xml/ns/javaee"

xmlns:web="http://java.sun.com/xml/ns/javaee/web-
SO S Shos il
xsi:schemalocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app 3 0.xsd"
= tiNebipr B wie msaor=E S50 >

19



5. web xml Bile Creation (1l

e EREieE
<servlet-name>My REST service </servlet-name>

<servlet-class>org.glassfish.jersey.servlet.ServletContainer</servlet-
SHESRERS

SN AR oSl SN i1
<param-name>jersey.config.server.provider.packages</param-name>
<param-value>

packageName, com. fasterxml.jackson.jaxrs.json</param-value>

< TREE AT Replace by
your package

name

s Tar et

20




5. web xmil Hile Creation (1)

<servlet-mapping>

<servlet-name>My REST service </servlet-name>

<url-pattern>/demg/*</url-pattern>

</servlet-mapping> :
Optional

</web-app>

NOTE: depending on the operating system the quotation marks are copied wrongly. Revise them
when you get an errot.

NOTE: You can create first the class and then the web.xml or vice-versa.

21
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6. Service API Deployment ,
- Sj zz;w‘..:t:cm Context !
C_':: RRRR |
S o |
0= |
* We deploy the service in the Tomcat server previously T |
created: Right click on the project - Run as =2 Run on s DL
Server =2 We select the server created = Finish S : s
* We will be asked to restart the server =2 we click on OK & o] e oo |
* If everything worked fine in the deployment, the service .. P E——
: . Properties 'ee ervers o (¥ Uata dource txplorer 5 Snippets onsole
will appear as synchronized. |
y ﬁTomcatv&O Server at localho [Started, Synchronized]
* Otherwise, we will have to click in the console to see the (o HellWord [Synchronize]
CITOf. (o < http://localhost:8080/HelloWorld/
* Do not worry 1if you get a 404 error in the browser. Estado HTTP 404 - /HelloWorld/
* NOTE: To see the console window, problems or error T Informe de estado
log: Window=> Show View=> General=> corresponding option T Lelovend
REasineta El recurso reguerido no esta disponible.

T T —— - - § T ———
23
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/. Testing 1t from Postman

* We can use any rest client, |

[B) Save v oo Vi

for instance Postman @( — > @ |
Params Authorization Headers (6) Body Pre-request Script Tests Settings Cookies
Fill in the address to e ® fom-cats ® scww-form-urencoded ® raw @ binary @ Graphal .
invoke:

http://localhost:8080/HelloWorld
/demo/hello

N annotation /
Included in
web.xml

Body (Cookies Headers (5) Test Results

@ status: 200 OK Time: 2.56s  Size: 161B Save Response

Your project

Pretty Raw Preview Visualize Text

= mQ
1 Hello Plain

name

25
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